
Just Enough Logging

What is Logging?
Logging is very useful during the development and debugging phase of an application.
This is especially the case when a debugger is not used or not applicable. Through the use
of logging, results of the programs can be printed and stored so that developers or even
users can view and understand the results of the program. However it is important to note
that printing logs in the programs increase the size and reduce its performance in terms of
speed. In server side applications like J2EE (Java 2 Enterprise Edition), this is especially
critical. Applications serving the corporate are mission critical and their performance is
extremely important. Leaving all print and debug statements into the program is not an
option. Also, it does not help that Java does not have preprocessing capabilities, which
allows the removal of these printing/debug statements and compilation time.

What is Log4J?
Log4J can be thought of as an improved System.out.println for loggging purposes.
Specifically it is a framework that allows enabling or disabling of logging at runtime
without modifying the programs and recompiling. Logging behavior can be controlled by
editing a configuration file, without touching the application binary. Log4J allows
logging output at arbitrarily fine granularity but also great ease. For example, a developer
can log messages at different severity such as whether it is a debug message, warning
message or error message. During development time of the application, all messages can
be configured to be printed, while at deployment time, only the more critical messages are
printed. This helps reduce the volume of logged output during deployment and minimize
the cost of logging. The diagram below shows the Java application using the log4j
framework and configuration file to carry out logging. The logging behaviour can be
modified in the configuration file.
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Advantages of using Log4J?
As compared to using System.out.println for logging
• Printing methods used for logging can always remain in application code because they

do not incur heavy process overhead for the application and assist in ongoing
debugging and monitoring of application code, thus proving useful in the long term. 

• Management of logging can be configured in an external configuration at runtime.
This makes it convenient without requiring the need of the recompilation of the
application.

• The ability to disable certain log statements while allowing others to print unhindered.
Log output can be organized into hierarchies and priority levels ( we will be explaining
this later. )

What is this tutorial about?
In this tutorial we will first look at a very simple Log4J example before proceeding to
explain the certain important concepts of Log4J. We have found that most developers are
interested in getting started as soon as possible before zooming into the details. A second
portion of the tutorial will make sure that most of the important features in Log4J are
covered. Ultimately, this tutorial aims to provide just enough information and knowledge
to implement logging in a typical application. 



Tutorial Part 1 : Step 1 – Start Eclipse and create a new Project

Goto Start Menu->OpenEnterpriseX->Eclipse. Create a new project MyFirstLogging. If
you are not familiar with Eclipse, we suggest that you go through the JustEnoughEclipse
tutorial. Leave the rest as defaults and click Finish.



Tutorial Part 1 : Step 2 – Create a sample Logging Class

Goto File->New->Class in Eclipse to create new class. Name the class MyFirstLogging
and put it inside the package app. Set the options as the diagram below and click Finish.



Tutorial Part 1 : Step 3 – Provide the implementation for the Class

Key in the following class shown in the table below. 

The log4j environment in this example is configured programmatically. This is illustrated
in the line:

BasicConfigurator.configure();

The invocation of this method creates a rather simple log4j setup.

In a real life scenario, this is typically not the case. A property or XML file will be used to
configure Log4J instead. The output to the log is carried by the lines logger.info or
logger.warn. These lines will be used to replace the System.out.println statements in a
program. The important thing to note is that during this time, a concious effort is being
made to identify the severity of the messages. A logger.warn message is more severe than
a logger.info message. The different severity of the messages will be discussed later.
During runtime, a developer will be able to control that only messages of certain severity
goes to the log file.

 package app; 
 // Import log4j classes.
 import org.apache.log4j.Logger;
 import org.apache.log4j.BasicConfigurator;
 public class MyFirstLogging {
   static Logger logger = Logger.getLogger(MyFirstLogging.class);
   public static void main(String[] args) {
     BasicConfigurator.configure();
     logger.info("Start");
     logger.warn("Warning message");
     logger.info("Stop");
   }
 }
 



Tutorial Part 1 : Step 4 – Add the Log4j library 
Goto Project->Properties->Java Build Path and select the Libaries Tab.
Click on Add External JARs... The Log4j jar file (log4j-1.2.8.jar) is located in 
C:\OpenEnterpriseX\v0.1\dev\frameworks\jakarta-log4j-1.2.8\dist\lib. 

This is of course assuming OpenEnterpriseX is installed in C:\OpenEnterpriseX default
directory. Click Open followed by OK.



Tutorial Part 1 : Step 5 – Run the Logging Class
Right click on the MyFirstLogging class. On the speed menu choose Run->Debug Java
Application.

 
Output



Log4J Concepts
The Part 1 of the tutorial creates a very simple example of using Log4J. In real life
scenarios, much more capabilities will be used than illustrated above. In this section, the
important concepts like Appenders, Levels and Hierarchies will be introduced.

• Logger
The first concept to understand is that of a logger. The advantages of any logging API
over plain System.out.println resides in its ability to disable certain log statements
while allowing others to print.  In Log4J, to configure the behaviour of writing to logs,
the entity call a logger is used. A logger can be named and have characteristics. For
example, a logger can be named as "com" or "com.x". Logger can have characteristics,
for example the logger "com" can be configured to write to log files while logger
"com.x" can be configured to write logs to the console. 

A logger can also be arranged in a hierachical manner using the naming conventions.
For example, "com" is the parent of "com.x". The names are case sensitive. The reason
for arranging a logger in a hierachical manner is to allow for inheritance of behaviour.
Allowing behaviours in logger to be inherited and will make the control of the loggers
easy.

So how is a logger created in the program. The following are some examples:

Retrieve the root logger:
Logger logger = Logger.getRootLogger(); 

Create a new logger:
Logger logger = Logger.getLogger("com");

Instantiate a static logger globally, based on the name of the class:
static Logger logger = Logger.getLogger(test.class);

• Appenders
Log4j allows logging requests to print to multiple destinations. The output destination
is called an appender. The following appenders are supported 

• console, files
• GUI components
• remote socket servers
• JMS
• NT Event Loggers
• remote UNIX Syslog daemons. 

More than one appender can be attached to a logger. In the tutorial above, the default
appender used is the Console Appender.



• Levels
There are two important concepts about Levels. 

• Loggers may be assigned levels. 
The default level of a Logger is DEBUG. In the tutorial above, the Logger
is using the default Debug level. The level of a logger can of course be
changed programmatically or through a configuration file. 

• Logging request can be carried out at different levels.
In the tutorial above, the class MyFirstLogging logs at INFO level
(logger.info("Start")) and WARN level (logger.warn("Warning
message")) .

Standard levels are as follows:
• DEBUG
• INFO
• WARN
• ERROR
• FATAL 

They are defined in the org.apache.log4j.Level class. The standard levels are ranked as
follows:  DEBUG < INFO < WARN < ERROR < FATAL.  

A logging request is said to be enabled if its level is higher than or equal to the level
of its logger. The examples below illustrate this.

Logger – WARN Level
logger.debug("Msg"); //Will NOT print to log
logger.info("Msg");    //Will NOT print to log
logger.warn("Msg");   //Will print to log
logger.error("Msg");   //Will print to log
logger.fatal("Msg");   //Will print to log

Logger – ERROR Level
logger.debug("Msg"); //Will NOT print to log
logger.info("Msg");    //Will NOT print to log
logger.warn("Msg");   //Will NOT print to log
logger.error("Msg");   //Will print to log
logger.fatal("Msg");   //Will print to log



• Level Inheritance
As mentioned earlier, a logger can be arranged in a hierachical manner and certain
behaviour can be inherited. Level is one of this behaviour. The level assigned to a
logger "com" will be inherited by it's child "com.x". Of course, "com.x" can override
this behaviour if required.

• Layout
The layout is responsible for formatting the logging request according to the user's
wishes, whereas an appender takes care of sending the formatted output to its
destination.

• Configuration file
The Layouts, Levels, Appenders, Loggers mentioned above can all be configured in a
configuration file in a property format or XML format. An application using Log4J can
read in this property file to configure the Log4J behaviour.



Tutorial Part 2
The second part of this tutorial will extend the first tutorial and make use of the concepts
above.

Tutorial Part 2 : Step 1 – Add a second class for logging
Goto File->New->Class and add a class named MySecondLogging. Make sure the
settings are as the diagram below. Click Finish when done.



Key in the content of the class as follows

package app;
import org.apache.log4j.Logger;
public class MySecondLogging {

static Logger logger = Logger.getLogger
(MySecondLogging.class);

public void doSomething()
{

logger.debug("Debug Message");
}

}

Modify MyFirstLogging class as follows. The first four modifications modify
[change/redirect?] the class to make use of a a property file call app.log4j.config for
configuration. The next two modifications allows the MyFirstLogging class to make a
call to the MySecondLogging class.

 package app; 
 // Import log4j classes.
 import org.apache.log4j.Logger;
 //import org.apache.log4j.BasicConfigurator;              Modified
 import org.apache.log4j.PropertyConfigurator;           //Modified
 public class MyFirstLogging {
   static Logger logger = Logger.getLogger(MyFirstLogging.class);
   public static void main(String[] args) {

     //BasicConfigurator.configure();                      Modified
     PropertyConfigurator.configure("app/log4j.config"); //Modified
     logger.info("Start");
     logger.warn("Warning message");
     MySecondLogging msl = new MySecondLogging(); //Modified
     msl.doSomething();                           //Modified
     logger.info("Stop");
   }
 }
 



Tutorial Part 2 : Step 2 – Add a Log4J configuration file
Goto File->New->File to create a new file log4j.config in the app directory. Make sure
the configurations is [the same] as the diagram below.



Tutorial Part 2 : Step 3 – Setup the configuration file
Setup the contents of the configuration file to be as the table below. The configuration
below set up the root logger to use the ConsoleAppender. It is the only logger thus all
logs will go to the console. The output will be logged using a patten(see the keyword
ConversionPattern in the table below). The following are the explanation of the patterns.

%d     - Date in ISO8601 format 
%[t]   - Output the name of the thread that generated the logging event
%-5p  - Priority of the logging event
%c     -  Used to output the category of the logging event.
%x     - Used to output the NDC (nested diagnostic context) associated with the thread
that generated the logging event.
%m    - Output the application supplied message associated with the logging event.
%n     - Outputs the platform dependent line separator character or characters

# Set root logger level to DEBUG and its only appender to stdout.
log4j.rootLogger=WARN, stdout 
# Set to a ConsoleAppender.
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
# Use PatternLayout.
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%d [%t] %-5p %c %x-%m%n

In the above example, logs are arranged in a manner as defined by us using a layout called
the PatternLayout. This is often the most common layout to use. However it is also
important to note that there are other layouts available. They are as follows:

• Simple layout
Formats the output in a very simple manner, it prints the Level, then a dash '-' and then
the log message. 

• PatternLayout
Formats the output based on a conversion pattern specified, or if none is specified, the
default conversion pattern. 

• HTML layout
Formats the output as a HTML table. 

• XMLLayout-- org.apache.log4j.xml.XMLLayout
Formats the output as a XML. 



Tutorial Part 2 : Step 4 – Run the class 
Save all the files and Right Click on the MyFirstLogging class. Select on Run->Debug
Java Application. The output should be as the diagram below. Only messages of level of
WARN and above will be printed.

Output



Tutorial Part 2 : Step 5 – Change the logger level to DEBUG
Change the LEVEL of the rootLogger to DEBUG.

# Set root logger level to DEBUG and its only appender to stdout.
log4j.rootLogger=DEBUG, stdout 
# Set to a ConsoleAppender.
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
# Use PatternLayout.
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%d [%t] %-5p %c %x-%m%n



Tutorial Part 2 : Step 6 – Run the class again
Save all the files and Right Click on the MyFirstLogging class. Select on Run->Debug
Java Application. The output should be as the diagram below. All messages of level
DEBUG and above will be displayed.



Tutorial Part 2 : Step 7 – Add another Appender
Add the following lines in blue to the log4j.config configuration file. This will output the
logs to a log file mylogfile.log on top of the console. This file will be rolled over when it
reaches 200KB. When roll-over occurs, the old version of mylogfile.log is automatically
moved to and renamed as mylogfile.log.1. The roll-over feature in making sure that log
files do not get too large and affects the performance of writing logs in the application.
However, logs are not lost as before it is roll-over, a backup of the file will be made.

# Set root logger level to DEBUG and its only appender to stdout.
log4j.rootLogger=DEBUG, stdout , logfile
# Set to a ConsoleAppender.
log4j.appender.stdout=org.apache.log4j.ConsoleAppender
# Use PatternLayout.
log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
log4j.appender.stdout.layout.ConversionPattern=%d [%t] %-5p %c %x-%m%n
log4j.appender.logfile=org.apache.log4j.RollingFileAppender
log4j.appender.logfile.File=mylogfile.log
log4j.appender.logfile.MaxFileSize=200KB
# Keep one backup file
log4j.appender.logfile.MaxBackupIndex=1
log4j.appender.logfile.layout=org.apache.log4j.PatternLayout
log4j.appender.logfile.layout.ConversionPattern=%p %t %c - %m%n



Tutorial Part 2 : Step 8 – Run the class again
Save all the files and Right Click on the MyFirstLogging class. Select on Run->Debug
Java Application. The logs will be written to the console and a log file call mylogfile.log.
Goto the project directory(MyFirstLogging under the eclipse workspace directory) and
look for the file mylogfile.log. It should look like the following. Notice the logs are
output according to the patterns in the configuration file.

INFO main app.MyFirstLogging - Start
WARN main app.MyFirstLogging - Warning message
DEBUG main app.MySecondLogging - Debug Message
INFO main app.MyFirstLogging - Stop


